Inhalt

BinTerm - Hilfe
Inhaltsverzeichnis
Weiter
Inhaltsverzeichnis:
1. | Einleitung
1.1 | Abfragearten
1.2 | Bedienung Protokoll
2. | Konfigurationsmöglichkeiten
2.1 | Einstellung der Schnittstelle
2.1.1 | Übertragung über TCP/IP
2.2 | Einstellung der Datenwandlung
2.3 | Begrenzung der Protokollierung
2.4 | Mitprotokollierung der Zeit / PlugIn
3. | Was tun wenn...
4. | Anhang
4.1 | Schnittstellenbelegungen
4.2 | ASC-II - Tabelle
4.3 | ANSI - Tabelle
 | V 2.1.1B04, Markus Müller
www.MmVisual.de

Mail: mm@MmVisual.de
Weiter


1. Einleitung

Zurück Weiter
1. Einleitung:
BinTerm ist ein Datenspion, mit dem ein Datenstrom zwischen seriellen Schnittstellen ausspioniert und auf dem Bildschirm dargestellt werden kann.
Wahlweise können die empfangenen Bytes in ASC-II, ANSI, OEM, Hexadezimal oder Dezimal angezeigt werden. Zeichen, die einen Zeilenumbruch hervorrufen sollen, sind frei konfigurierbar.
Durch einen Parametrierbaren Filter kann die Anzeige begrenzr werden.
Das empfangene Protokoll ist in einer Text- oder RTF- Datei speicherbar.
Mit der PlugIn- Funktion wandeln Sie Ihr Datenprotokoll in sichtbare Textzeichen für die Protokollierung.
Zurück


1.1 Abfragearten

1.1 Abfragearten:
Abfrage ohne Datenspion:
Am Spionage- PC benötigt BinTerm 2 serielle Schnittstellen. Die Software überträgt die Daten von der einen zur anderen Schnittstelle. Zusätzlich können die Handshake- Signale protokolliert werden.

Abfrage mit Datenspion:

Wird BinTerm mit einem Datenspion genutzt, so müssen beide Datenrichtungen die gleiche Baudrate haben.
Mit diesem Abfragestecker ist die Spionage in beide Richtungen mit nur einer seriellen Schnittstelle möglich (ideal für Diagnosen mit einem Laptop).
Bei 2 Abfragesteckern können die Daten im Duplexbetrieb abgefragt werden.


1.2 Bedienung Protokoll

1.2 Bedienung Protokoll:
In diesem Beispiel sehen Sie eine Protokollierung im ANSI-Format, Zeilenwechsel, zyklische Zeitprotokollierung, Hex-Format, Dezimal-Darstellung mit Zeitanzeige nach Zeilenwechsel.
Änderungen in der Konfiguration sind sofort wirksam.
Protokoll:
Alle über die serielle Schnittstelle empfangenen Zeichen werden anhand der Datenwandlung in sichtbaren Text gewandelt und angezeigt. Alle Zeichen, die von der PC- Seite empfangen werden, sind schwarz, die von der SPS- Seite rot dargestellt. Die zyklische Protokollierung wird blau eingetragen.
Wollen Sie einen Teil der Aufzeichnung in anderen Programmen weiterverwenden, so können Sie den Text markieren, mit Strg+C in die Zwischenablage kopieren. Mit Strg+V kann der Text in einem anderen Editor oder Schreibprogramm eingefügt werden.

Pause/Weiter- Taste:
Mit der Pause- Taste halten Sie die Protokollierung an. Alle in dieser Zeit empfangenen Zeichen werden gelöscht. Wird die Weiter- Taste betätigt, so wird die Protokollierung fortgesetzt.
Löschen- Taste:
Leert das Protokoll.
Speichern- Taste:
Speichert das Protokoll in eine Text- oder RTF- Datei. In der RTF- Datei werden die Texte bunt gespeichert.
Online- Log:
Mit dieser Funktion kann online zur Protokollanzeige eine Datei geschrieben werden. Bei setzen des Häkchens wird eine neue Datei erstellt. Während der Protokollierung in die Datei können andere Programme lesend auf die Log-Datei zugreifen. Solange der Log in die Datei läuft, ist das Häkchen gesetzt. Wahlweise kann der Online-Log als Text- oder als RTF- Datei gespeichert werden. In der RTF- Datei werden die Texte bunt gespeichert.
Suchen von Zeichen im Protokoll:
Drücken Sie STRG+F um einen Suchstring einzugeben. Mit F3 können sie die nächste Zeichenfolge finden. Eine gefundene Zeichenfolge wird markiert. Kann BinTerm keine Zeichenfolge mehr finden, wird eine Meldung ausgegeben. Die nächste Suche mit F3 beginnt wieder vom Protokollanfang.
Die von der Schnittstelle gelesen Daten, werden zuerst in einem Ringpuffer zwischengespeichert. Kommen sehr schnell viele Daten, so wird zuerst die Schnittstelle abgefragt, anschliessend werden die Bytes anhand der Codeseite gewandelt und in das Protokoll geschrieben. Durch den Ringpuffer werden die Daten nicht in Echtzeit angezeigt, was den Vorteil hat, dass alle Bytes sicher gelesen werden. Nach der Protokollierung werden die Zeichen aus dem Ringpuffer gelöscht.
Mit der Hilfe- Taste oder F1 gelangen Sie immer zum entsprechenden Thema. Findet BinTerm die Hilfe- Datei "BinTerm.chm" nicht, so wird die Hilfe im Internet gesucht.
Die Schliessen- Taste beendet BinTerm und speichert die Einstellungen in der Konfigurationsdatei "BinTerm.ini".


2. Konfigurationsmöglichkeiten

2. Konfigurationsmöglichkeiten:
 | Sprache:
 | Sie können momentan zwischen der deutschen und englischen Sprache wechseln. Die Sprache kann im Abschnitt Schnittstelle umgestellt werden.
2.1 | Schnittstelle:
 | Die Art, welche Datenrichtungen abgefragt werden soll, ist frei einstellbar. Die serielle Schnittstelle ist in den üblichen Eigenschaften wie COM- Nummer, Baudrate, Datenbits, Stoppbits und Parität konfigurierbar. Kommen nur selten Daten, so kann eine Soundausgabe eingeschaltet werden.
2.2 | Datenwandlung:
 | In der Datenwandlung wird festgelegt, wie die empfangenen Zeichen dargestellt werden. Standardmässig sind Wandlungen in ASC-II, ANSI, OEM- Zeichen, Dezimal und Hexadezimal zur Auswahl angeboten. In der unteren Liste werden alle zu wandelnden Zeichen (0-255) angezeigt.
2.3 | Zeit:
 | In der Zeit kann eingestellt werden: - Uhrzeit vor jeder neuen Zeile - automatisch Datum und Uhrzeit- Protokollierung alle xx Minuten Dies ist vor allem hilfreich, wenn Daten über einen längeren Zeitraum aufgezeichnet werden.


2.1 Einstellung der Schnittstelle

2.1 Einstellung der Schnittstelle:

Art:
Ohne BinTerm |
Abfrage von PC und SPS: | Daten werden von beiden Richtungen empfangen und im Protokoll angezeigt.
Abfrage von PC: | Protokollierung von Daten, die von der PC-Seite gesendet wurden.
Abfrage von SPS: | Protokollierung von Daten, die von der SPS-Seite gesendet wurden.
gleichzeitige Abfrage: | Es werden Daten von beiden Richtungen empfangen. Jede Datenleitung wird über eine serielle Schnittstelle zu BinTerm übertragen. Alle Daten werden in 2 Fenstern protokolliert, womit voller Duplexbetrieb unterstützt wird. Bei Speicherung des aufgezeichneten Protokolls wird zuerst der Text von der linken, anschliessend von der rechten Box gespeichert.
Abfrage ohne Datenspion | Es wird keine Hardware benötigt. Die empfangenen Daten von der einen Schnittstelle werden zur anderen durch den Computer übertragen. Über die Fusssteuerung müssen Sie die Funktionsweise der Steuersignale einstellen. Es können zusätzlich Baudraten von 57600 und 115200 Baud eingestellt werden.
Verbindung über TCP/IP | Mit dieser Einstellung können Daten über das TCP/IP- Protokoll weitergeleitet werden. Eine nähere Beschreibung finden Sie unter 2.1.1

Am Spionagestecker müssen die Jumper wie in der Grafik im BinTerm- Programm gesetzt werden!
Schnittstelle A / B:
Die serielle Schnittstelle, in der der Datenspion am PC eingesteckt wird. Ist die Abfrage ohne Datenspion eingestellt, so müssen Sie die zu spionierenden Geräte direkt am BinTerm- PC einstecken.
Es werden nur Schnittstellen zur Auswahl angeboten, die dem Betriebssystem bekannt sind.
Baudrate:
Baudraten sind von 300 - 38400 Baud einstellbar. Höhere Baudraten sind durch die Schutzbeschaltung des Spionagesteckers nicht möglich.
In der Abfrage ohne Datenspion können bis zu 115200 Baud eingestellt werden.
Mit der Auswahl Andere kann eine anderen beliebige Baudrate eingestellt werden. Aber Vorsicht! Es kann sein, dass das Öffnen der Schnittstelle mehrere Sekunden dauert. Kann der PC die Baudrate nicht einstellen, so erscheint eine Fehlermeldung. Benutzen Sie nur für die Abfrageart Abfrage ohne Datenspion und Verbindung über TCP/IP eine grössere Baudrate als 38400!
Datenbits:
Datenbits sind 7oder 8 auswählbar.
Stoppbits:
Stoppbits sind 1 oder 2 auswählbar.
Parität:
Die Parität kann zwischen Keine, Gerade oder Ungerade (None, Even, Odd) ausgewählt werden.
Das Häkchen "Buchse im PC" ist standardmässig angewählt. Ist die Option ausgeschaltet, so werden die empfangenen Daten der anderen Seite zugeordnet und die Texte dementsprechend vertauscht protokolliert.
Ist die Option "Sound, wenn Daten ankommen" eingeschaltet, so erscheint bei jedem empfangenen Byte ein Ton in den Lautsprechern. Kommen mehr als 20 Bytes pro Sekunde, so wird die Option ausgeschaltet.
CTS/DTR- Änderungen können nur mitprotokolliert werden, wenn Sie Abfrage ohne Datenspion ausgewählt haben.

Damit Konfigurationsänderungen wirksam werden, müssen Sie die Schaltfläche [image] betätigen.

Tipp:
Wollen Sie Daten mit unterschiedlichen Schnittstellenparametern (Baudrate, Datenbits, Stoppbits, Parität) in beide Richtungen gleichzeitig abfragen, so benötigen Sie 2 Spionagestecker. Öffnen Sie das BinTerm- Programm 2 mal. Im ersten stellen Sie "Abfrage vom PC" ein, im 2. "Abfrage von SPS" sowie die entsprechenden Schnittstellenparameter.


2.1.1 Übertragung über TCP/IP

2.1.1 Übertragung über TCP/IP:

In der Einstellung TCP/IP gibt es 2 Betriebsarten:

1. Variante Abfrage mit dem Zusatz, dass die empfangenen Daten über das TCP/IP- Protokoll an die angegebene Adresse gesendet werden. In diesem Beispiel wird die Abfrage von PC und SPS gezeigt:

Parametrierung BinTerm 1:
Art: von PC und/oder SPS oder Abfrage ohne Datenspion.
Empfangene Daten zur TCP/IP- Adresse übertragen anwählen.
TCP/IP- Adresse von BinTerm 2 eingeben. 		Parametrierung BinTerm 2:
Art: Verbindung über TCP/IP.
Daten von anderem BinTerm über TCP/IP mitprotokollieren anwählen.
TCP/IP- Adresse von BinTerm 1 eingeben.

Das 1. BinTerm arbeitet autark, das 2. zeigt zusätzlich die gleichen Daten wie das 1. BinTerm an. Die Datenwandlung kann an beiden Programmen frei eingestellt werden.
2. Variante Abfrage über grössere Distanzen.

Parametrierung BinTerm 1:
Art: Verbindung über TCP/IP.
Daten von anderem BinTerm über TCP/IP mitprotokollieren nicht anwählen.
TCP/IP- Adresse von BinTerm 2 eingeben. 		Parametrierung BinTerm 2:
Art: Verbindung über TCP/IP.
Daten von anderem BinTerm über TCP/IP mitprotokollieren nicht anwählen.
TCP/IP- Adresse von BinTerm 1 eingeben.

Das 1. BinTerm liest die Daten vom 1. Fremdgerät, stellt die Zeichen dar und überträgt sie via TCP/IP- Protokoll an den 2. PC. Dort läuft BinTerm, das die Daten auch anzeigt und auf die Schnittstelle dem 2. Fremdgerät zur Verfügung stellt. Und umgekehrt.

Was heisst TCP/IP, LAN, WAN?
TCP/IP ist ein Datenprotokoll, das Datenpakete über ein Netzwerk (auch im Internet) weitertransportieren kann.
LAN nennt man ein Verbindungsnetzwerk innerhalb einer Firma (das Netzwerk).
WAN ist ein Verbindungsnetzwerk Weltweit (das Internet). Eine WAN- Verbindung kann entweder über ein analoges Modem oder ein ISDN-Modem erfolgen. Eine WAN- Verbindung über DSL ist nicht möglich, da der PC keine TCP/IP- Adresse vom Internet- Provider zugeordnet bekommt (siehe TCP/IP- Adresse unter DFÜ- Verbindung).
Die Verbindung vom einem zum anderen PC kann mit einem Netzwerkkabel oder über Modem realisiert werden.

Einstellung/Parametrierung der 1. Variante:
Stellen Sie im 1. BinTerm die Abfrageart von PC und/oder SPS oder Abfrage ohne Datenspion ein. Setzen Sie das Häkchen Empfangene Daten zur TCP/IP- Adresse übertragen.
Am 2. BinTerm müssen Sie die Art Verbindung über TCP/IP auswählen sowie das Häkchen Daten von anderem BinTerm über TCP/IP mitprotokollieren setzen. Zusätzlich muss die TCP/IP- Adresse eingestellt werden.

Einstellung/Parametrierung der 2. Variante:
An beiden BinTerm- Programmen müssen Sie die Art Verbindung über TCP/IP auswählen sowie das Häkchen Daten von anderem BinTerm über TCP/IP mitprotokollieren wegnehmen. Zusätzlich muss die TCP/IP- Adresse eingestellt werden.

Einstellung der TCP/IP- Adressen:
Die TCP/IP- Adresse lokal ist die Adresse des lokalen Computers und muss unter TCP/IP- Adresse anderer PC im 2. BinTerm- Programm eingestellt werden.
Wenn Sie eine Verbindung über das lokale Netzwerk (LAN) herstellen wollen, so benutzen Sie die Netzwerkadresse.
Um eine Verbindung über das Internet herstellen zu können, müssen Sie eine Adresse aus den DFÜ-Verbindungen benutzen. In DFÜ- Verbindungen wird nur eine Adresse angezeigt, wenn eine Verbindung in das Internet via Modem oder ISDN besteht. Bei jeder neuen Anwahl ins Internet wird dort die momentan aktive Adresse angezeigt.
Neben dem Eingabefeld der TCP/IP- Adresse ist eine runde Lampe, deren Farbe sich bei TCP/IP- Verbindung ändert:

rot | TCP/IP- Adresseingabe ist nicht korrekt
grau | TCP/IP- Verbindung nicht nötig
gelb | Es besteht keine Verbindung mit einem anderen BinTerm.
grün | Es besteht eine Verbindung mit einem anderen BinTerm.

Sind die TCP/IP- Adressen korrekt eingegeben, so findet BinTerm selbstständig das andere Programm. Sollte innerhalb von 3 Sekunden die Anzeige nicht auf grün wechseln, so haben Sie vermutlich eines der beiden Programme falsch Parametriert oder es besteht keine TCP/IP- Verbindung zum anderen PC. Das TCP/IP- Protokoll muss natürlich auf den PC's installiert sein.

2 BinTerm- Programme können mit der ersten Variante miteinander sogar auf dem gleichen PC kommunizieren. Dazu müssen Sie in beiden Programmen die gleiche TCP/IP- Adresse angegeben. Damit können Sie die empfangenen Daten mit verschiedenen Datenwandlungen protokollieren. Mit der 2. Variante ist dies nicht möglich.


2.2 Einstellung der Datenwandlung

2.2 Einstellung der Datenwandlung:

1. Auswahl der Datenwandlung:
In dieser Auswahlbox wählen Sie die Codeseite aus. Standardmässig kann die Datenwandlung in ASC-II, ANSI, OEM, Dezimal oder Hexadezimal eingestellt werden.
Mit der rechten Maustaste können Sie eine Codeseite kopieren oder eine neue leere erstellen. Bei schreibgeschützter Konfigurationsdatei können jedoch keine Änderungen vorgenommen werden.

2. Datenwandlung - empfangenes Byte in Zeichen auf dem Protokoll:
Angewählte Einträge erzeugen einen Zeilenwechsel im Protokoll.
Ist eine benutzerspezifische Codeseite aktiv, so können Sie die anzuzeigenden Zeichen mit Doppelklick ändern. Eine Einschränkung der Eingabe gibt es nicht. Wird ein Code leer gelassen, so erscheint auch kein Zeichen im Protokoll.
3. Zeilenwechsel bei Änderung der Datenrichtung:
Ändert sich die Richtung der empfangenen Bytes, so wird ein Zeilenwechsel ausgelöst.
4. Zeilenwechselzeichen:
Jeder Eintrag in dieser Liste erzeugt einen Zeilenwechsel im Protokoll. Mit Doppelklick kann der Eintrag aus der Liste entfernt werden.
5. Text bei Zeilenende PC:
Wird ein Zeilenwechsel durch ein Zeichen vom PC hervorgerufen, so erscheint dieser Text. Anschliessend beginnt im Protokoll eine neue Zeile.
6. Text bei Zeilenende SPS:
Wird ein Zeilenwechsel durch ein Zeichen von der SPS hervorgerufen, so erscheint dieser Text. Anschliessend beginnt im Protokoll eine neue Zeile.
7. Zeilenendetext auch bei Zeilenanfang:
Diese Option zeigt den Zeilenendetext auch bei Zeilenanfang wenn das 1. Byte empfangen wird.
Alle Änderungen sind sofort wirksam.
Bei beenden von BinTerm werden die Einstellungen in der Konfigurationsdatei gespeichert. Änderungen an der Codeseite (1) und an dem anzuzeigenden Text (2) werden sofort in der Konfigurationsdatei abgelegt.


2.3 Begrenzung der Protokollierung

2.3 Begrenzung der Protokollierung:

Startzeichen der Protokollierung:
Alle ausgewählten Zeichen lassen die Protokollfunktion beginnen. Wurde kein Zeichen ausgewählt, so ist die Protokollierung immer eingeschaltet.
Je nach Datenrichtung wird das Start- Zeichen statt schwarz grau oder statt rot dunkelrot Protokolliert.
Ausgewählte Startzeichen:
Hier werden alle ausgewählte Zeichen dargestellt. Mit Doppelklick können Sie die Zeichen aus der Liste entfernen.
Stoppzeichen der Protokollierung:
Alle ausgewählten Zeichen stoppen die Protokollfunktion.
Ausgewählte Stoppzeichen:
Hier werden alle ausgewählte Zeichen dargestellt. Mit Doppelklick können Sie die Zeichen aus der Liste entfernen.

Protokollierung nach xxx Zeichen stoppen:
Nach Start der Protokollierung durch das Startzeichen, werden die nachfolgenden xxx Zeichen protokolliert, anschliessend hält die Protokollierung an. Mit lesen des Stoppzeichens kann die Protokollierung schon früher unterbrochen werden.
Zeilenwechsel nach Stopp:
Stoppt die Protokollierung, wird automatisch ein Zeilenwechsel ausgeführt.
Der Status der Protokollfunktion wird in der Statusleiste (unten) angezeigt.
Alle Änderungen sind sofort wirksam. Bei beenden von BinTerm werden die Einstellungen in der Konfigurationsdatei gespeichert.


2.4 Mitprotokollierung der Zeit / PlugIn

2.4 Mitprotokollierung der Zeit / PlugIn:

Uhrzeit bei neuer Zeile anzeigen:
Nach einem Zeilenwechsel, wenn neue Daten ankommen wird die aktuelle Uhrzeit vorrangestellt.
Millisekunden anzeigen:
Zeigt die Uhrzeit mit Millisekunden an. (Stunde:Minute:Sekunde.Millisekunde) Mit dieser Option kann das zeitliche Verhalten genau festgestellt werden.

Alle xxx Minuten ein Protokolleintrag:
Bei setzen der Option oder bei leeren des Protokolls wird sofort ein Eintrag mit Datum und Uhrzeit vorgenommen und alle 1...999 Minuten wiederholt. Die Protokollierung der Daten wird in einer neuen Zeile fortgesetzt.
Wurde 0 Minuten eingetragen erscheint kein Eintrag.
Der zyklische Protokolleintrag wird blau protokolliert.

Benutze Plugin:
Mit dieser Option aktivieren Sie die PlugIn- Funktion. Kann die PlugIn- DLL nicht korrekt angesprochen werden, nimmt BinTerm das Häkchen wieder weg.
In dem Eingabefeld kann der Name der DLL angegeben werden.
Bei aktiven PlugIn wird auf der rechten Seite eine Kurzbeschreibung sowie Versionsnummer der DLL angezeigt.
Die Parameter- Taste öffnet einen Parametrierungsdialog des PlugIn's.
Was ist eine PlugIn- Funktion?
Ein PlugIn kann die ankommenden Zeichen einer Schnittstelle in Textzeichen für die Anzeige wandeln. Somit können komplizierte Übertragungsprotokolle entschlüsselt und als klartext protokolliert werden. PlugIn's sind immer Programmbibliotheken (DLL's). Benötigen Sie ein PlugIn, so schreiben Sie mir ein E-Mail.
Alle Änderungen sind sofort wirksam. Bei beenden von BinTerm werden die Einstellungen in der Konfigurationsdatei gespeichert.


3. Was tun wenn...

3. Was tun wenn ...

... keine Daten im Protokoll aufgezeichnet werden?
Überprüfen Sie, ob der richtige COM- Port ausgewählt ist und ob alle Stecker korrekt zusammengesteckt sind.
Wenn die Schnittstelle geöffnet wird, darf keine Fehlermeldung erscheinen.
Die Datenübertragung zwischen den Fremdsystemen muss funktionieren, wenn der Spionagestecker nicht dazwischengeschaltet ist. Funktioniert die Datenübertragung nicht, so deutet dies auf ein Verkabelungsproblem hin. Bauen Sie in diesem Fall ein Nullmodem in die Leitung ein.
Bei Verlängerung vom Spionagestecker zum BinTerm- PC benötigen Sie ein Kabel, das 1:1 verbunden ist.
... nur korrupte Daten im Protokoll?
Überprüfen Sie die Schnittstelleneinstellung anhand der COM- Nummer, Baudrate, Parität, Daten- und Stoppbits. Viele Übertragungsprotokolle benutzen keine Parität und nur ein Stoppbit.

... die Richtung der ankommenden Daten fehlerhaft angezeigt wird?
Bei 32- Bit- Systemen ist ein direkter Zugriff auf die serielle Schnittstelle nicht möglich. Wenn die 2 auszuspionierenden Systeme ohne die kleinste zeitliche Verzögerung die Datenrichtung ändern, so ist es dem Betriebssystem nicht mehr möglich dies korrekt BinTerm mitzuteilen.

... bei Programmstart BinTerm meldet "Schnittstelle COMn lässt sich nicht öffnen"?
Wenn nach Änderung auf eine gültige COM- Nummer immer noch keine gültigen Daten im Protokoll erscheinen, starten Sie BinTerm neu.
Sollten weiterhin keine Daten angezeigt werden, so müssen Sie den Spionagestecker vom PC entfernen (damit der Computer beim neu starten kein Gerät findet und die Schnittstelle nicht automatisch blockiert) und neu starten.
Ist an dieser Schnittstelle ein Modem konfiguriert (Systemsteuerung), so kann es sein, dass das DFÜ-Netzwerk die Schnittstelle blockiert.

... nicht alle Bytes korrekt angezeigt werden?
Verkleinern Sie das Programm BinTerm. Windows benötigt dadurch weniger Zeit für die Aktualisierung auf dem Bildschirm wodurch der Schnittstellenabfrage mehr Zeit bleibt.
... beim beenden von BinTerm erscheint die Fehlermeldung: "Konfigurationsdatei nicht speicherbar"?
Erstellen Sie eine Verknüpfung zu BinTerm auf dem Desktop. Das Verzeichnis "Ausführen in" muss gleich eingestellt werden wie das vom "Ziel". Somit wird die Konfigurationsdatei im gleichen Ordner wie BinTerm.exe gesichert. Arbeiten Sie mit Windows NT oder 2000 so müssen Sie auch die entsprechenden Rechte auf diesen Ordner besitzen.

... keine Soundausgabe obwohl Sound bei Daten eingeschaltet ist?
Kontrollieren Sie, ob die Soundkarte funktioniert und ob in der Systemsteuerung > Sounds oder Akustische Signale im "Standardton" ein Klang hinterlegt ist.

Sollten Sie dennoch vor unlösbaren Probleme stehen, so schauen Sie auf meiner Homepage nach, ob es bereits eine aktuellere Version als Ihre gibt. Die Versionsnummer können Sie im Reiter "Info" erfahren.
Ist Ihr Problem dennoch vorhanden, so schreiben Sie mir ein E-Mail mit der genauen Beschreibung.


4. Anhang

4.0 Anhang
4.1 | Schnittstellenbelegungen Belegung der seriellen Schnittstelle, Erstellung von Verbindungskabel
4.2 | ASC-II - Tabelle mit nationalen Ersatzzeichensätzen
4.3 | ANSI - Tabelle Erzeugung der Zeichen 128-255 in der Textverarbeitung


4.1 Schnittstellenbelegungen

4.1 Schnittstellenbelegung
Steckerbelegung nach V.24 (ISO 2110):
Signal | PC 9 Pol. Sub-D | PC 25 Pol. Sub-D
TxD | 3,O | 2,O
RxD | 2,I | 3,I
RTS | 7,O | 4,O
CTS | 8,I | 5,I
DTR | 4,O | 20,O
DSR | 6,I | 6,I
DCD | 1,I | 8,I
Ring | 9,I | 22,I
GND | 5 | 7
Erde | Geh. | Geh.

O | = Ausgang
I | = Eingang

Verbindungskabel PC 9Pol. - PC 9Pol.
Signal | PC |  | PC
 | 9 Pol. Sub-D |  | 9 Pol. Sub-D
RxD | 2 |  | 3
TxD | 3 |  | 2
RTS | 7 |  | 8
CTS | 8 |  | 7
DTR | 4 |  | 1,6
DSR | 6 |  | 4
DCD | 1 |  | 4
GND | 5 |  | 5
Erde | Geh. |  | Geh.
Ring | 9 | frei | 9

Verbindungskabel PC 9Pol. - PC 25Pol.
Signal | PC |  | PC
 | 9 Pol. Sub-D |  | 25 Pol. Sub-D
RxD | 2 |  | 2
TxD | 3 |  | 3
RTS | 7 |  | 5
CTS | 8 |  | 4
DTR | 4 |  | 6,8
DSR | 6 |  | 20
DCD | 1 |  | 20
GND | 5 |  | 7
Erde | Geh. |  | Geh.
Ring | 9 | frei | 22

Verlängerungskabel sind immer 1:1 verbunden. Es müssen immer alle Steckerstifte und das Gehäuse verdrahtet werden.
Das Gehäuse wird immer mit der Abschirmung des Kabels verbunden.


4.2 ASC-II - Tabelle

4.2 ASC-II - Tabelle
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
0 | 00 | ^@ | NUL | 32 | 20 | Leer | 64 | 40 | @ | 96 | 60 | '
1 | 01 | ^A | SHO | 33 | 21 | ! | 65 | 41 | A | 97 | 61 | a
2 | 02 | ^B | STX | 34 | 22 | " | 66 | 42 | B | 98 | 62 | b
3 | 03 | ^C | ETX | 35 | 23 | # | 67 | 43 | C | 99 | 63 | c
4 | 04 | ^D | EOT | 36 | 24 | $ | 68 | 44 | D | 100 | 64 | d
5 | 05 | ^E | ENQ | 37 | 25 | % | 69 | 45 | E | 101 | 65 | e
6 | 06 | ^F | ACK | 38 | 26 | & | 70 | 46 | F | 102 | 66 | f
7 | 07 | ^G | BEL | 39 | 27 | ' | 71 | 47 | G | 103 | 67 | g
8 | 08 | ^H | BS | 40 | 28 | ( | 72 | 48 | H | 104 | 68 | h
9 | 09 | ^I | HT | 41 | 29 | ) | 73 | 49 | I | 105 | 69 | i
10 | 0A | ^J | LF | 42 | 2A | * | 74 | 4A | J | 106 | 6A | j
11 | 0B | ^K | VT | 43 | 2B | + | 75 | 4B | K | 107 | 6B | k
12 | 0C | ^L | FF | 44 | 2C | , | 76 | 4C | L | 108 | 6C | l
13 | 0D | ^M | CR | 45 | 2D | - | 77 | 4D | M | 109 | 6D | m
14 | 0E | ^N | SO | 46 | 2E | . | 78 | 4E | N | 110 | 6E | n
15 | 0F | ^O | SI | 47 | 2F | / | 79 | 4F | O | 111 | 6F | o
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
16 | 10 | ^P | DLE | 48 | 30 | 0 | 80 | 50 | P | 112 | 70 | p
17 | 11 | ^Q | DC1 | 49 | 31 | 1 | 81 | 51 | Q | 113 | 71 | q
18 | 12 | ^R | DC2 | 50 | 32 | 2 | 82 | 52 | R | 114 | 72 | r
19 | 13 | ^S | DC3 | 51 | 33 | 3 | 83 | 53 | S | 115 | 73 | s
20 | 14 | ^T | DC4 | 52 | 34 | 4 | 84 | 54 | T | 116 | 74 | t
21 | 15 | ^U | NAK | 53 | 35 | 5 | 85 | 55 | U | 117 | 75 | u
22 | 16 | ^V | SYN | 54 | 36 | 6 | 86 | 56 | V | 118 | 76 | v
23 | 17 | ^W | ETB | 55 | 37 | 7 | 87 | 57 | W | 119 | 77 | w
24 | 18 | ^X | CAN | 56 | 38 | 8 | 88 | 58 | X | 120 | 78 | x
25 | 19 | ^Y | EM | 57 | 39 | 9 | 89 | 59 | Y | 121 | 79 | y
26 | 1A | ^Z | SUB | 58 | 3A | : | 90 | 5A | Z | 122 | 7A | z
27 | 1B | ^[ | ESC | 59 | 3B | ; | 91 | 5B | [ | 123 | 7B | {
28 | 1C | ^\ | FS | 60 | 3C | < | 92 | 5C | \ | 124 | 7C | |
29 | 1D | ^] | GS | 61 | 3D | = | 93 | 5D | ] | 125 | 7D | }
30 | 1E | ^^ | RS | 62 | 3E | > | 94 | 5E | ^ | 126 | 7E | ~
31 | 1F | ^_ | US | 63 | 3F | ? | 95 | 5F | _ | 127 | 7F | DEL
DEC | Dezimal
HEX | Hexadezimal
Zeic. | Dargestelltes Zeichen

Nationale Ersatz- Zeichensätze
DEC | 35 | 64 | 91 | 92 | 93 | 94 | 95 | 96 | 123 | 124 | 125 | 126
HEX | 23 | 40 | 5B | 5C | 5D | 5E | 5F | 60 | 7B | 7C | 7D | 7E
ASC-II | # | @ | [ | \ | ] | ^ | _ | ` | { | | | } | ~
Britisch | £ | @ | [ | \ | ] | ^ | _ | ` | { | | | } | ~
Deutsch | # | § | Ä | Ö | Ü | ^ | _ | ` | ä | ö | ü | ß
Finnisch | # | @ | Ä | Ö | Å | Ü | _ | é | ä | ö | å | ü
Franko- Kanadisch | # | à | â | ç | ê | î | _ | ô | é | ù | è | û
Französisch | £ | à | ° | ç | § | ^ | _ | µ | é | ù | è | ¨
Holländisch | £ | ¾ | ÿ | ½ | | | ^ | _ | ` | ¨ | ƒ | ¼ | '
Italienisch | £ | § | ° | ç | é | ^ | _ | ù | à | ò | è | ì
Norwegisch | § | @ | Æ | Ø | Å | ^ | _ | ` | æ | ø | å | |
Portugisisch | # | ' | Ã | Ç | Õ | ^ | _ | ` | ã | ç | õ | ~
Schwedisch | # | É | Ä | Ö | Å | Ü | _ | é | ä | ö | å | ü
Schweizerisch | ù | à | é | ç | ê | î | è | ô | ä | ö | ü | û
Spanisch | £ | § | ¡ | Ñ | ¿ | ^ | _ | ` | ° | ñ | ç | ~


4.3 ANSI - Tabelle

Zurück
4.3 ANSI- Tabelle
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
0 | 00 | ^@ |  | 32 | 20 | Leer | 64 | 40 | @ | 96 | 60 | '
1 | 01 | ^A |  | 33 | 21 | ! | 65 | 41 | A | 97 | 61 | a
2 | 02 | ^B |  | 34 | 22 | " | 66 | 42 | B | 98 | 62 | b
3 | 03 | ^C |  | 35 | 23 | # | 67 | 43 | C | 99 | 63 | c
4 | 04 | ^D |  | 36 | 24 | $ | 68 | 44 | D | 100 | 64 | d
5 | 05 | ^E |  | 37 | 25 | % | 69 | 45 | E | 101 | 65 | e
6 | 06 | ^F |  | 38 | 26 | & | 70 | 46 | F | 102 | 66 | f
7 | 07 | ^G |  | 39 | 27 | ' | 71 | 47 | G | 103 | 67 | g
8 | 08 | ^H | BS | 40 | 28 | ( | 72 | 48 | H | 104 | 68 | h
9 | 09 | ^I | TAB | 41 | 29 | ) | 73 | 49 | I | 105 | 69 | i
10 | 0A | ^J | LF | 42 | 2A | * | 74 | 4A | J | 106 | 6A | j
11 | 0B | ^K |  | 43 | 2B | + | 75 | 4B | K | 107 | 6B | k
12 | 0C | ^L |  | 44 | 2C | , | 76 | 4C | L | 108 | 6C | l
13 | 0D | ^M | CR | 45 | 2D | - | 77 | 4D | M | 109 | 6D | m
14 | 0E | ^N |  | 46 | 2E | . | 78 | 4E | N | 110 | 6E | n
15 | 0F | ^O |  | 47 | 2F | / | 79 | 4F | O | 111 | 6F | o
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
16 | 10 | ^P |  | 48 | 30 | 0 | 80 | 50 | P | 112 | 70 | p
17 | 11 | ^Q |  | 49 | 31 | 1 | 81 | 51 | Q | 113 | 71 | q
18 | 12 | ^R |  | 50 | 32 | 2 | 82 | 52 | R | 114 | 72 | r
19 | 13 | ^S |  | 51 | 33 | 3 | 83 | 53 | S | 115 | 73 | s
20 | 14 | ^T |  | 52 | 34 | 4 | 84 | 54 | T | 116 | 74 | t
21 | 15 | ^U |  | 53 | 35 | 5 | 85 | 55 | U | 117 | 75 | u
22 | 16 | ^V |  | 54 | 36 | 6 | 86 | 56 | V | 118 | 76 | v
23 | 17 | ^W |  | 55 | 37 | 7 | 87 | 57 | W | 119 | 77 | w
24 | 18 | ^X |  | 56 | 38 | 8 | 88 | 58 | X | 120 | 78 | x
25 | 19 | ^Y |  | 57 | 39 | 9 | 89 | 59 | Y | 121 | 79 | y
26 | 1A | ^Z |  | 58 | 3A | : | 90 | 5A | Z | 122 | 7A | z
27 | 1B | ^[ |  | 59 | 3B | ; | 91 | 5B | [ | 123 | 7B | {
28 | 1C | ^\ |  | 60 | 3C | < | 92 | 5C | \ | 124 | 7C | |
29 | 1D | ^] |  | 61 | 3D | = | 93 | 5D | ] | 125 | 7D | }
30 | 1E | ^^ |  | 62 | 3E | > | 94 | 5E | ^ | 126 | 7E | ~
31 | 1F | ^_ |  | 63 | 3F | ? | 95 | 5F | _ | 127 | 7F |
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
128 | 80 | € |  | 160 | A0 | Leer | 192 | C0 | À | 224 | E0 | à
129 | 81 |  |  | 161 | A1 | ¡ | 193 | C1 | Á | 225 | E1 | á
130 | 82 | ‚ |  | 162 | A2 | ¢ | 194 | C2 | Â | 226 | E2 | â
131 | 83 | ƒ |  | 163 | A3 | £ | 195 | C3 | Ã | 227 | E3 | ã
132 | 84 | „ |  | 164 | A4 | ¤ | 196 | C4 | Ä | 228 | E4 | ä
133 | 85 | … |  | 165 | A5 | ¥ | 197 | C5 | Å | 229 | E5 | å
134 | 86 | † |  | 166 | A6 | ¦ | 198 | C6 | Æ | 230 | E6 | æ
135 | 87 | ‡ |  | 167 | A7 | § | 199 | C7 | Ç | 231 | E7 | ç
136 | 88 | ˆ |  | 168 | A8 | ¨ | 200 | C8 | È | 232 | E8 | è
137 | 89 | ‰ |  | 169 | A9 | © | 201 | C9 | É | 233 | E9 | é
138 | 8A | Š |  | 170 | AA | ª | 202 | CA | Ê | 234 | EA | ê
139 | 8B | ‹ |  | 171 | AB | « | 203 | CB | Ë | 235 | EB | ë
140 | 8C | Œ |  | 172 | AC | ¬ | 204 | CC | Ì | 236 | EC | ì
141 | 8D |  |  | 173 | AD |  | 205 | CD | Í | 237 | ED | í
142 | 8E | Ž |  | 174 | AE | ® | 206 | CE | Î | 238 | EE | î
143 | 8F |  |  | 175 | AF | ¯ | 207 | CF | Ï | 239 | EF | ï
DEC | HEX | Zeic. | Name | DEC | HEX | Zeic. | DEC | HEX | Zeic. | DEC | HEX | Zeic.
144 | 90 |  |  | 176 | B0 | ° | 208 | D0 | Ð | 240 | F0 | ð
145 | 91 | ‘ |  | 177 | B1 | ± | 209 | D1 | Ñ | 241 | F1 | ñ
146 | 92 | ’ |  | 178 | B2 | ² | 210 | D2 | Ò | 242 | F2 | ò
147 | 93 | “ |  | 179 | B3 | ³ | 211 | D3 | Ó | 243 | F3 | ó
148 | 94 | ” |  | 180 | B4 | ´ | 212 | D4 | Ô | 244 | F4 | ô
149 | 95 | • |  | 181 | B5 | µ | 213 | D5 | Õ | 245 | F5 | õ
150 | 96 | – |  | 182 | B6 | ¶ | 214 | D6 | Ö | 246 | F6 | ö
151 | 97 | — |  | 183 | B7 | · | 215 | D7 | × | 247 | F7 | ÷
152 | 98 | ˜ |  | 184 | B8 | ¸ | 216 | D8 | Ø | 248 | F8 | ø
153 | 99 | ™ |  | 185 | B9 | ¹ | 217 | D9 | Ù | 249 | F9 | ù
154 | 9A | š |  | 186 | BA | º | 218 | DA | Ú | 250 | FA | ú
155 | 9B | › |  | 187 | BB | » | 219 | DB | Û | 251 | FB | û
156 | 9C | œ |  | 188 | BC | ¼ | 220 | DC | Ü | 252 | FC | ü
157 | 9D |  |  | 189 | BD | ½ | 221 | DD | Ý | 253 | FD | ý
158 | 9E | ž |  | 190 | BE | ¾ | 222 | DE | Þ | 254 | FE | þ
159 | 9F | Ÿ |  | 191 | BF | ¿ | 223 | DF | ß | 255 | FF | ÿ
DEC | Dezimal
HEX | Hexadezimal
Zeic. | Dargestelltes Zeichen
Erzeugung der Zeichen 128-255 in der Textverarbeitung:
Schalten Sie "Num-Look" ein, drücken und halten Sie die "ALT"- Taste. Für das ‰-Zeichen (Code 137) müssen Sie "0137" im Zehner-Block tippen und die "ALT"- Taste loslassen. Der Zeichencode muss immer in Dezimaler schreibweise mit 4 Ziffern geschrieben werden.